
PROCEDIMENTI EXCEL 

EXCEL 
Ø Estendere la selezione al limite dei dati 

CTRL + MAIUSC + tasto freccia 
 

Ø Formule – operatori aritmetici

 
 

Ø Riferimenti assoluti 
$ à blocca 
 

Ø La funzione SUM (SOMMA) 
=SUM (intervallo) à per selezionare intervallo uso :  
 

Ø La funzione IF (SE) 
=IF (test;[se_vero];[se_falso]) 
 

Ø La funzione ROUND (ARROTONDA) 
=ROUND(num; num_cifre) 
 

Ø La funzione CONCAT (CONCAT) 
=CONCAT(testo1; [testo2]; ...) 
 

Ø Ordinamento dei dati 
1. Selezionare una cella all'interno dei dati. 
2. Selezionare Home > Sort and Filter.  
Oppure selezionare Data > Sort. 
3. Selezionare un'opzione: 



• Ordina dalla A alla Z dispone la colonna selezionata 
• Ordina dalla Z alla A dispone la colonna selezionata 
• Ordinamento personalizzato ordina i dati in più colonne applicando diversi criteri di 
ordinamento. 
 

Ø Filtraggio dati  
Data e cliccare su Filter (oppure Home > Sort and Filter > Filter). 
 
Il comando trasforma ogni cella della prima riga in un menu a tendina. Cliccando sulla 
freccia, possiamo togliere la spunta dai valori che desideriamo escludere. 
 

LEZIONE 2 – DISTRIBUZIONI DI FREQUENZA E RAPPRESENTAZIONI 
GRAFICHE  

Ø Distribuzioni di frequenza  
 
Il metodo più semplice per costruire una distribuzione di frequenza in Excel è una 
tabella Pivot. 
• Per creare una Tabella Pivot in Excel aprire il foglio di lavoro che contiene i dati grezzi 
(es. dati1.xlsx) e selezionare Insert → PivotTable. 
• Nella finestra di dialogo PivotTable: 
1. Lasciate selezionata l’opzione Select a table or range e inserite l’intervallo delle 
celle (es. B1:B21). 
2. Selezionate l’opzione New Worksheet e fate click su OK. 
 
• Nella finestra PivotTable Fields: 
1. Trascinate l’etichetta della variabile che deve essere analizzata e inseritela nel 
riquadro ROWS. 
2. Trascinate una seconda volta questa stessa etichetta nel riquadro VALUES. Questa 
seconda etichetta viene trasformata trasformata in Count of (nome della 
variabile), a indicare che nell’area DATI sarà visualizzato un conteggio delle frequenze 
di ciascuna modalità. 
 
• Per aggiungere una colonna con le frequenze relative: 
1. Trascinate un’altra volta l’etichetta della variabile che deve essere analizzata nel 
riquadro VALUES. 
2. Cliccare sulla tendina a fianco della seconda etichetta nel campo VALUES e 
selezionare nel successivo menu l'opzione Value Field Settings. 
3. Nella successiva finestra di dialogo nella scheda Summarize Values By impostare 
Count e nella scheda Show Values As al posto di nessun calcolo impostare % 
of Grand Total. 



Ø Distribuzione di frequenza in classi  
1. Creare la tabella pivot (frequenze assolute) dei dati non raggruppati in classi. 
2. Nella tabella pivot fare clic con il pulsante destro del mouse su un valore e scegliere 
Group. 
3. Nella finestra Group modificare se necessario il valore minimo, il valore massimo e 
l’ampiezza nelle classi. 
4. Selezionare OK. 
 

Ø Diagramma a torta  
• Selezionare la tabella delle frequenze (assolute o relative). 
• Selezionare Insert → Insert Pie or Doughnut Chart e selezionare un grafico 
• Fare clic sul grafico e quindi sulle icone accanto al grafico per modificarne l’aspetto. 
 

Ø Diagramma a barre  
• Selezionare la tabella delle frequenze (assolute o relative). 
• Selezionare Insert → Insert Column or Bar Chart e selezionare un grafico 
• Fare clic sul grafico e quindi sulle icone accanto al grafico per modificarne l’aspetto. 
 

Ø PivotChart e PivotTable 
Il comando PivotChart & PivotTable ci consente di creare simultaneamente una 
distribuzione di frequenza e la sua rappresentazione grafica partendo dallo stesso 
dataset. 
Nella finestra PivotTable Fields: 
1. Trascinate l’etichetta della variabile che deve essere analizzata e inseritela nel 
riquadro Axis (Categories). 
2. Trascinate una seconda volta questa stessa etichetta nel riquadro VALUES per 
definire il tipo di frequenza desiderata. 
 

Ø Istogramma 
1. A partire dai dati grezzi 
• Selezionare i dati. 
• Selezionare Insert → Histogram e scegliere Histogram 
• Per modificare il numero di classi cliccare con il tasto destro del mouse sull’asse x e 
selezionare Format Axis. 
 
2. A partire dalle distribuzioni di frequenza 
• Selezionare la tabella delle frequenze (assolute o relative). 
• Selezionare Insert → Insert Column or Bar Chart e selezionare Clustered Column 
• Cliccare con il tasto destro su una barra e selezionare Format Data Series dal menu 
di scelta rapida. 
• Nel riquadro Format Data Series, modificare i dati in Gap Width per eliminare gli 
spazi tra le barre. 



 

LEZIONE 3 – INDICI DI POSIZIONE E DI VARIABILITA’  
Ø Indici di posizione 

 

 
 

Ø Indici di variabilità  

 
 

Ø Funzioni statistiche di excel  



 
 

Ø Data analysis tool 
• Selezionare Data → Data Analysis 
• Nella finestra di dialogo Data Analysis selezionare Descriptive Statistics e fare clic su 
OK. 
• Nella finestra di dialogo Descriptive Statistics, inserire l’intervallo delle celle che 
contengono i dati nel campo Input Range. 
• Selezionare NewWorksheet e Summary Statistics e cliccare OK 
 

Ø Descriptive Summary (PHStat) 
• Selezionare Add-Ins → PHStat → Descriptive Statistics → Descriptive Summary 
• Nella finestra di dialogo Descriptive Summary, inserire l’intervallo delle celle che 
contengono i dati nel campo Raw Data Cell Range. 
 
• Il comando Descriptive Summary accetta anche dati relativi a più gruppi. 
• I dati relativi a diversi gruppi possono essere organizzati in due modi: 
I. Multiple Groups – Unstacked – Più gruppi contenuti in più colonne, una per ogni 
gruppo. 
II. Multiple Groups – Stacked – Più gruppi impilati in una sola colonna. In questo caso è 
necessario specificare dove è contenuta la variabile che definisce l’appartenenza ai 
gruppi (nel campo Grouping Variable Cell Range). 
 

Ø Creare un boxplot con outlier  
• Selezionare i dati 
• Selezionare Insert → Recommended Charts 
• Nella finestra di dialogo Insert Chart, selezionare All Charts → Box and Whisker e clic 
OK. 
 

Ø Creare un boxplot (PHStat) 
Selezionare Add-Ins → PHStat → Descriptive Statistics → Boxplot 
• Nella finestra di dialogo Boxplot, inserire l’intervallo delle celle che contengono i dati 
nel campo Raw Data Cell Range. 



 
Nota. Nello stesso grafico possono essere rappresentati più boxplot che sintetizzano 
la distribuzione del carattere considerato in gruppi diversi. 
I dati relativi a diversi gruppi possono essere organizzati in due modi: Unstacked e 
Stacked. 
 

Ø Standardizzazione  
= STANDARDIZE(x; media; dev_standard) 

 

LEZIONE 4 – DISTRIBUZIONE NORMALE  
Ø Verificare la normalità  

1. Utilizzo di grafici per analizzare la forma della distribuzione (boxplot, istogramma o 
poligono delle frequenze). 
2. Valutazione delle statistiche descrittive. 
3. Valutazione di un normal probability plot ovvero di una rappresentazione grafica 
utile valutare la normalità dei dati. Un metodo comunemente utilizzato è quello 
chiamato q-q plot (quantile-quantile plot). 
 

Ø Normal Probability Plot (PHStat) 
Selezionare Add-Ins → PHStat → Probability & Prob. Distributions → Normal Probability 
Plot. 
• Nella finestra di dialogo, inserire l’intervallo delle celle che contengono i dati nel 
campo Variable Cell Range. 
• Per aggiungere la linea retta che rappresenta la perfetta normalità 
 

LEZIONE 5 – INTERVALLI DI CONFIDENZA  
Ø Intervallo di confidenza per la media  

1. FUNZIONI STATISTICHE DI EXCEL 
▪ Funzione per calcolare il margine d’errore IC con varianza della popolazione nota: 
=CONFIDENCE.NORM(alpha; standard_dev; size) 
▪ Funzione per calcolare il margine d’errore IC con varianza della popolazione non 
nota: 
=CONFIDENCE.T(alpha; standard_dev; size) 
 
2. DATA ANALYSIS TOOL 
Calcolo del ME dell’intervallo di confidenza per la stima della media con varianza non 
nota: 
• Selezionare Data → Data Analysis 



• Nella finestra di dialogo Data Analysis selezionare Descriptive Statistics e fare clic su 
OK. 
• Nella finestra di dialogo Descriptive Statistics, inserire l’intervallo delle celle che 
contengono i dati nel campo Input Range. 
• Selezionare Summary Statistics e Confidence Level for Mean, specificare il livello di 
confidenza e cliccare OK. 
 
3. PHStat 
 

 
 
 

 
 
 
 
 



 
 

 

 
 

LEZIONE 6 – VERIFICA DI IPOTESI  
Ø Verifica di ipotesi sulla media  

• Verifico normalità  



 

 

LEZIONE 7 – CONFRONTO TRA DUE GRUPPI  
Ø Confronto misure di sintesi  

PHStat → Descriptive Statistics → Descriptive Summary → Multiple Groups – Stacked 
 

 



Ø Confronto boxplot (PHStat) 
1.Costruire il box-plot dei valori della variabile pulsazioni cardiache. 
2.Fare clic con il pulsante destro del mouse sul grafico, quindi scegliere Select Data 
3.Nella finestra di dialogo Select data Source, cliccare sul pulsante Edit nella parte 
destra della finestra (Horizontal (Category) Axis Labels). 
 

 
 
4.Nella finestra Axis Labels, inserire l'intervallo di celle contenente i dati sulla base 
della quale si vuole stratificare l’analisi. 
 

 
 

Ø Test di confronto tra due medie con campioni dipendenti (PHStat) 
MODO 1  
• Verifico normalità  
• PHStat → Two-Sample Tests (Unsummarized Data) → Paired t Test 

MODO 2  

• Verifico normalità  
• PhStat con one sample t test della var d  

 

 

 



 
 

Ø Confronto tra due medie con campioni indipendenti  
• Verifico normalità 
• PHStat → Two-Sample Tests (Unsummarized Data) → F Test for Diqerences in 

Two Variances… 
• Se varianze uguali à Two-Sample Tests (Unsummarized Data) à Pooled 

variance T-test 
Se variance diverse à Two-Sample Tests (Unsummarized Data) à Separate-
variance T-test 

 

LEZIONE 8 – RELAZIONE TRA DUE VARIABILI CATEGORICHE  
Ø Tabelle di contingenza  

• Aprire il foglio di lavoro che contiene i dati grezzi (es. dati_trattamento.xlsx) e 
selezionare Insert → PivotTable. 
• Nella finestra di dialogo PivotTable: 
1. Lasciate selezionata l’opzione Select a table or range e inserite l’intervallo delle 
celle (es. B1:C501). 
2. Selezionate l’opzione New Worksheet e cliccare su OK. 
• Nella finestra PivotTable Fields: 
1. Trascinate l’etichetta della variabile di riga e inseritela nel riquadro ROWS. 
2. Trascinate una seconda volta questa stessa etichetta nel riquadro VALUES. 
3. Trascinate l’etichetta della variabile di colonna e inseritela nel riquadro 
COLOUMNS. 
 
PHStat 
• Selezionare Add-Ins → PHStat → Descriptive Statistics → Two-Way Tables & Charts 
(questa procedura sfrutta la funzione di Excel PivotTable). 



• Nella finestra di dialogo Two-Way Tables & Charts 
1. Inserire l’intervallo di dati relativo alla variabile di riga nel riquadro Raw Variable Cell 
Range. 
2. Inserire l’intervallo di dati relativo alla variabile di Colonna nel riquadro Column 
Variable Cell Range. 
3. Click OK. 
 

Ø Frequenze relative  

 
 

Ø Frequenze condizionate  



 
 

Ø Grafici a barre  
• Selezionare la tabella delle frequenze (assolute, relative o condizionate). 
• Selezionare Insert → Insert Column or Bar Chart e selezionare un grafico. 
• Fare clic sul grafico e quindi sulle icone accanto al grafico per modificarne l’aspetto. 
(uso diagramma a barre sovrapposte con frequenze condizionate per confronto) 
 

Ø Indice di associazione PHStat 
• Selezionare Add-Ins → PHStat → Multiple-Sample Tests →Chi-Square Test 

 

LEZIONE 9 – RELAZIONE TRA DUE VARIABILI NUMERICHE  
Ø Diagramma a dispersione  

• Selezionare tutte le celle contenenti i valori delle due variabili. 
• Selezionare la scheda Insert. 
• Nella sezione Charts, cliccare su Scatter e seleziona l'opzione Scatter. 
• Aggiungere titoli agli assi. 
 

Ø Covarianza  

 

 



 

Ø CoeViciente di correlazione di Pearson  
 

 
 

Ø Matrice di correlazione  
• Selezionare Data → Data Analysis 
• Nella finestra di dialogo Data Analysis selezionare Correlation e fare clic su OK. 
• Nella finestra di dialogo Correlation, inserire l’intervallo delle celle che contengono i 
dati nel campo Input Range. 
• Selezionare NewWorksheet e cliccare OK. 
 

Ø Costruire una variabile stratificatrice di indicazione  
• Costruisco due limiti à liminf; limsup 
• Funzione IF (-3 e 3 dev standard per identificare outlier)à se <=-3 o > 3 1 se no 0 
• Applico a tutte le celle  

 


